Acquia's Third-Party Email & Landing Page Builder Causing Delays in Campaign Studio's Email Builder Loading

Incident Report for Acquia, Inc.

Resolved

The underlying cause of the issue affecting the builder has been addressed. All affected services have been restored.
Posted Mar 10, 2025 - 19:45 UTC

Investigating

Acquia Campaign Studio is currently affected by delays in the email builder's loading process due to an issue with our third-party provider. We are actively investigating the root cause and will share more details once available.
Posted Mar 10, 2025 - 16:01 UTC
This incident affected: Acquia Campaign Studio.