Degraded Portals Performance

Incident Report for Acquia Inc

Resolved

We have resolved the issue causing degraded Portals performance for some customers. Contact Customer Support for help on Acquia DAM Community if you continue to experience any ongoing issues.
Posted May 06, 2026 - 00:33 UTC

Monitoring

A fix has been implemented for the issue causing degraded Portals performance and we're monitoring to ensure stability.
Posted May 05, 2026 - 23:21 UTC

Identified

We've identified the issue causing degraded Portals performance for some customers and we are working on a fix.
Posted May 05, 2026 - 23:08 UTC

Update

We are still investigating an issue where some customers are encountering degraded performance when loading Portals.
Posted May 05, 2026 - 22:13 UTC

Investigating

We are investigating an issue where some customers are encountering degraded performance when loading Portals.
Posted May 05, 2026 - 19:43 UTC
This incident affected: Acquia DAM (Acquia DAM, Portals) and Acquia DAM.