Service for all affected Acquia Source has been restored

Incident Report for Acquia Inc

Resolved

The underlying cause of this Acquia Source service interruption has been addressed. All affected Acquia Source services have been restored. All services are operational at this time.
Posted Nov 18, 2025 - 18:11 UTC

Monitoring

Acquia Source Platform (source.acquia.com) is now accessible, and the issue has been resolved. Our team will continue to monitor the situation to ensure ongoing stability. We will provide additional updates when available.
Posted Nov 18, 2025 - 14:54 UTC

Identified

Acquia is currently investigating an interruption of service for Acquia Source Platform (source.acquia.com), which is currently inaccessible. This interruption is not expected to impact customer CMS or sites hosted on Acquia Source. Our teams are actively working on a resolution. We will provide a full update once the service is fully restored.
Posted Nov 18, 2025 - 13:52 UTC
This incident affected: Acquia Source.