Investigating Login Issues with Acquia Campaign Studio and Campaign Factory,

Incident Report for Acquia Inc

Resolved

The login issues affecting Acquia Campaign Studio and Campaign Factory have been completely resolved, and all systems are fully operational.
Posted Jun 01, 2026 - 08:49 UTC

Monitoring

We have resolved the service interruption affecting Acquia Campaign Studio and Campaign Factory, where users were experiencing login failures. Our engineering and operations teams are actively monitoring the situation to ensure platform stability and performance remain optimal.
We will continue to keep a close watch on the system to prevent any further recurrence.
Posted Jun 01, 2026 - 07:20 UTC

Investigating

We are currently investigating a service interruption affecting Acquia Campaign Studio and Campaign Factory, where users are experiencing login failures. Our engineering and operations teams are actively triaging the situation to identify the root cause. We treat login disruptions with the highest priority and will provide regular updates here as we uncover more information.
Posted Jun 01, 2026 - 05:21 UTC
This incident affected: Acquia Campaign Studio and Acquia Campaign Factory.