Acquia is experiencing difficulties with customers submitting support tickets.

Incident Report for Acquia Inc

Resolved

This incident has been resolved and Acquia Support systems are available now.
Posted Jun 16, 2025 - 11:51 UTC

Update

Acquia is continuing to investigate the issue and will provide additional updates as soon as they are available. If you need to reach Support, please submit a support ticket via this link: https://acquia.my.site.com/s/contactsupport or call the Acquia Support number listed here: https://docs.acquia.com/service-offerings/support/support-users-guide/contacting-acquia-support.
Posted Jun 16, 2025 - 11:27 UTC

Update

Acquia is continuing to investigate the issue and will provide additional updates as soon as they are available.
Posted Jun 16, 2025 - 06:25 UTC

Investigating

Acquia is currently experiencing an issue with customers submitting support tickets. If you need to reach Support, please submit a support ticket via this link: https://acquia.my.site.com/s/contactsupport or call the Acquia Support number listed here: https://docs.acquia.com/service-offerings/support/support-users-guide/contacting-acquia-support.
Posted Jun 16, 2025 - 01:50 UTC
This incident affected: Acquia Support Systems.