Acquia Has Identified a Service Interruption Affecting All Campaign Studio Instances

Incident Report for Acquia Inc

Resolved

The issue impacting accessibility across all Campaign Studio instances has been fully resolved. Our internal engineering team has implemented a fix, and all systems are now operating normally.
Posted Mar 25, 2026 - 15:50 UTC

Investigating

Acquia has identified an issue impacting accessibility across all Campaign Studio instances. Our team is actively investigating the root cause and working to resolve it.
Posted Mar 25, 2026 - 13:55 UTC
This incident affected: Acquia Campaign Studio.