Performance and Loading Issues on EU Cloud Instances

Incident Report for Acquia, Inc.

Resolved

The underlying cause of the performance and loading issues on instances hosted in the EU cloud has been addressed. All affected services have been restored.
Posted Mar 11, 2025 - 19:57 UTC

Investigating

Acquia Campaign Studio is currently experiencing performance and loading issues on instances hosted on the EU cloud. We are actively investigating the root cause and will provide further details once they become available.
Posted Mar 11, 2025 - 18:51 UTC
This incident affected: Acquia Campaign Studio.