The issue appears to be resolved and previously impacted sites are now accessible. Our engineering team will continue to monitor the environment to ensure stability.
If you are still experiencing issues with your site, please respond to the support ticket opened for your environment or contact our support team so we can assist further. Additional updates will be shared as more information becomes available.
Posted Mar 13, 2026 - 03:42 UTC
Update
Update: Our engineering team continues to investigate the load balancer issue. At this time, the impact appears to be limited to a subset of customer applications. Impacted customers have been contacted directly while we continue working toward resolution. Further updates will be shared as more information becomes available.
Posted Mar 13, 2026 - 02:10 UTC
Investigating
Acquia is currently investigating an outage impacting multiple load balancers across several regions.Our engineering team is actively engaged and working to identify the issue.