We are currently performing maintenance for Acquia Cloud Free
Incident Report for Acquia, Inc.
Resolved
This maintenance is now complete.
Posted 9 months ago. Jan 29, 2018 - 16:51 UTC
Investigating
We are currently performing maintenance for Acquia Cloud Free. We will update again once this maintenance is complete.
Posted 9 months ago. Jan 29, 2018 - 14:29 UTC
This incident affected: Acquia Cloud Free.