Acquia has detected a temporary service interruption in the Acquia Support telephone system
Incident Report for Acquia, Inc.
Resolved
All affected phone services have been restored. All services are operational at this time.
Posted Aug 25, 2016 - 15:15 UTC
Monitoring
Phone services for Acquia Support are currently operation. We are monitoring the service at this time to ensure it remains stable.
Posted Aug 25, 2016 - 14:18 UTC
Investigating
We are currently investigating an interruption in telephone support for Acquia Support and Acquia Sales. During this service interruption, visit the Acquia Help Center (https://insight.acquia.com/support/) to file a ticket if you require assistance from Acquia Support. For Acquia Sales, please use the "Contact Us" form on the Acquia Homepage.

https://www.acquia.com/about-us/contact

We will provide additional information as it becomes available.
Posted Aug 25, 2016 - 13:40 UTC