We are currently performing maintenance for Acquia Cloud Free.
Incident Report for Acquia, Inc.
Resolved
This maintenance is now complete.
Posted 7 months ago. Jan 27, 2018 - 00:44 UTC
Monitoring
We are currently performing maintenance for Acquia Cloud Free. We will update again once this maintenance is complete.
Posted 7 months ago. Jan 26, 2018 - 19:40 UTC
This incident affected: Acquia Cloud Free.