Acquia has detected a temporary service interruption in the Acquia Support telephone system
Incident Report for Acquia, Inc.
Resolved
All affected phone services have been restored. All services are operational at this time.
Posted 7 months ago. Mar 22, 2018 - 10:02 UTC
Update
We are currently investigating an interruption in telephone support for Acquia Support. During this service interruption, visit the Acquia Help Center (https://insight.acquia.com/support/) to file a ticket if you require assistance from Acquia Support.

We will provide additional information as it becomes available.
Posted 7 months ago. Mar 22, 2018 - 09:33 UTC
Investigating
We are currently investigating an interruption in telephone support for Acquia Support. During this service interruption, visit the Acquia Help Center (https://insight.acquia.com/support/) to file a ticket if you require assistance from Acquia Support.

We will provide additional information as it becomes available.
Posted 7 months ago. Mar 22, 2018 - 09:30 UTC
This incident affected: Acquia Cloud Enterprise, Acquia Cloud Professional, Acquia Cloud UI, Acquia Cloud Site Factory, Acquia Cloud API, Acquia Search, Acquia Cloud Free, Acquia Lift, Acquia Cloud Edge, Acquia Content Hub, Acquia Support Systems, Acquia Cloud CD Pipelines, Acquia Cloud CD Environments, Node.js, Acquia DAM, Journey, and Acquia Commerce Manager.